Sunday, April 29, 2012

Thin Client

What is Thin Client

Thin Client is a low cost - centrally managed computer. It generally does not have any type of Disks, CDROM etc.
Uses computing resources of server and not client. As a result the performance of client machine is not dependent on the client hardware; rather it is depended on the server hardware.
Thin Client computing is not just sharing of Desktop - it is very advanced solution, where you have Complete security and privacy of data.
IN FACT IT IS MORE SECURED THAN FAT CLIENT ENVIRONMENT.




Thin Client is not suitable for following applications:
Heavy graphics - like Photoshop, Corel Draw or AutoCAD. (Up to some extent it does work, ask For demo)
Animation - 2D or 3D.
Heavy Multimedia applications (Web flash animation is OK - it works fine)
Gaming PC

Thin Client is suitable for following applications:
Any office applications
Any accounting package
Any client / server application
All types of ERP - even SAP can be run on Thin Clients.
Any DOS Application



ThinClient Benefits :

There are many benefits of ThinClient technology; some of them are as follows:
Lower IT administration costs. Thin clients are managed almost entirely at the server. The hardware has fewer points of failure.
Easier to secure. Thin clients can be designed in such a way that no application data ever resides on the client, centralizing malware protection and reducing the risks of physical data theft.
Lower hardware costs. Thin client hardware is generally cheaper because it does not contain a disk, application memory, or a powerful processor.
Less Energy Consumption. Dedicated thin client hardware has much lower energy consumption than thick client PCs. (Save around 51K – 20 system network)
Less network bandwidth. This is contrary to normal belief - BUT IT IS TRUE
Since terminal servers typically reside on the same high-speed network backbone as file servers, most network traffic is confined to the Server.
In a fat client environment if you open a 10MB document that's 10MB transferred from the file server to your PC. When you save it that's another 10MB from your PC to the server. When you print it the same happens again – another 10MB over the network to your print server and then 10MB onward to the printer. This is highly inefficient.
In a thin client environment only mouse movements, keystrokes and screen updates are transmitted from/to the end user. This can consume as little as 10-15 Kbit/s bandwidths.
Simple hardware upgrade path.
If the peak resource usage is above a pre-defined limit, it is a relatively simple process to add more resources to server (be it power, processing, storage), boosting resources to exactly the amount required.
The existing units can continue to serve alongside the new.
Whereas a thick client model requires an entire desktop unit be replaced, resulting in down-time for the user, and the problem of disposing of the old unit.
Less Wasted Hardware. Computer hardware is very environmentally damaging. Thin clients can remain in service longer and ultimately produce less surplus computer hardware than an equivalent thick client installation.

[ Click on Images to Enlarge ]

Saturday, April 28, 2012

Configuring BSNL DNA-A211 ITI router/modem to automatically connect

Configuring BSNL DNA-A211 ITI router/modem to automatically connect


If you have a ITI branded modem from BSNL, you probably wont find much documentation about setting it up for multi-use. The unit is actually an OEM product from SEMINDIA model # DNA-A211. This how-to will show you how to setup the router so that it automatically connects to the Internet on start-up, so that you don’t have to dial a connection.

First we shall setup the DSL connection:
1. Connect  to the modem/router through Wired Ethernet and enter 192.168.1.1 in the address bar. When prompted enter your username/password. It should be admin/admin by default. If you have forgotten the username/password, you can reset the modem by pressing the reset button on the back of the router with a pin for 10 seconds. You can access the modem at 192.168.1.1
2. Click on Advanced Setup -> WAN. You should see the following entries. The one we are interested in is the first one as shown. Click Edit.

step1

3. Enter the settings as shown below and click next.

step2

step3

step4

step5

Now to setup your wireless access, goto Wireless -> Wireless Bridge and choose the following:

step6

Also ensure that your wireless is enabled by going into Wireless -> Basic:

step8

Also ensure that your DHCP is enabled by going to Advanced Setup -> LAN and checking that your DHCP is enabled as shown below:

step7

Now go into Management -> Save/Reboot. This will save the settings and reboot your router. On restart the modem will establish the connection and you can simply connect to the wireless network.
Hope this helped. If you have any questions just ask in the comments section.

[ Click on the Images to enlarge. ]

MODEM CONFIGURATION / WIRELESS SECURITY - FOR TYPE 2 MODEM- WA 3002 G4


I.  Modem configuration:

  1. In the Internet Explorer, type 192.168.1.1 and press enter
  1. Type username as admin and password as admin and press OK
  1. Click “Advanced Setup”
  1. Click Edit button against VPI/VCI -0 and 35
  1. Click Next in the above screen
  1. Select PPP over Ethernet (PPPoE) in  the above screen
 

 
  1. In the above screen type username and password as given to you by BSNL
  2. In the PPPoE  Service Name, type a string say “dataone”
  3. Tick the following

Enable PPP Debug Mode
Bridge PPPoE Frames Between WAN and Local Ports (Default Enabled)
  1. Click Next
  1. Click Next in the above screen after selecting Enable NAT
  1. Click SAVE
  1. Click Save/Reboot in the above screen
  2. Click Management and choose Save/Reboot




  1. Click Save/Reboot button in the above screen –the changes are saved permanently

 II. Wireless security:

 This is important as otherwise the ADSL wireless works in an unsecured mode, which is unsafe.
  1. Click Wireless in the menu
        
  1. Click Security in the menu

  1. Click WPA-PSK in network authentication
  1. Type against WPA Pre Shared key -a key , for example say 12345678
  2. Click Save./ Apply
  3. Click Management
  4. Select Save/Reboot
  5. Click Save/ Reboot
  6. This completes the wireless security configuration
Note: The pre shared key which you have typed in the step number 4 is the key to be provided in the Laptop for getting  secured Wireless connectivity from Laptop for Broadband.

Switch interfaces configuration - Packet Tracer


Lab instructions

This lab will test your ability to configure speed, duplex, and vlan settings on a cisco switch interfaces.
1. Connect to Switch0 using console interface and configure each Switch0 fastethernet switchport for operation. Correct settings are :
- Port type : access port
- Speed : 100 Mbit/s
- Duplex mode : Full Duplex
- Autonegotiation disabled

2. PC "192.168.1.4" seems to be unable to ping other PCs in the network. Check switch configuration.
TIP : How many broadcast domains are there in this network ?

3. Choose the right cable to connect :
- Switch0 gigabitethernet 1/1 to Switch1 gigabitethernet 1/1
- Switch1 gigabitethernet 1/2 to Switch2 gigabitethernet 1/2

4. Configure those two links as trunk lines without using trunk negotiation between switches

Network diagram

Packet Tracer 5.3 - Switch interfaces configuration lab network diagram

Solution

Connect to Switch0 using console interface and configure each Switch0 fastethernet switchport for operation.
Switch(config)#interface FastEthernet0/1
switchport mode access
duplex full
speed 100
Switch(config)#interface FastEthernet0/2
switchport mode access
duplex full
speed 100
Switch(config)#interface FastEthernet0/3
switchport mode access
duplex full
speed 100
Switch(config)#interface FastEthernet0/4
switchport mode access
duplex full
speed 100

PC "192.168.1.4" seems to be unable to ping other PCs in the network. Check switch configuration.
Switch(config)#interface FastEthernet0/4
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 1


Choose the right cable to connect :
- Switch0 gigabitethernet 1/1 to Switch1 gigabitethernet 1/1
- Switch1 gigabitethernet 1/2 to Switch2 gigabitethernet 1/2

Packet Tracer 5.3 - Switch interfaces configuration lab solution

Configure those two links as trunk lines without using trunk negotiation between switches
On every interface that has to be configured for trunk operation, configure the following settings
Switch(config)#interface GigabitEthernet1/X
Switch(config-if)#switchport mode trunk

Verify interface operational mode using the "show interface GigabitEthernet1/X switchport command" :
Name: Gig1/2
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Another usefull ios command is "show interfaces trunk" :
Switch#sh interfaces trunk
Port        Mode         Encapsulation  Status        Native vlan
Gig1/2      on           802.1q         trunking      1

Port        Vlans allowed on trunk
Gig1/2      1-1005

Port        Vlans allowed and active in management domain
Gig1/2      1

Port        Vlans in spanning tree forwarding state and not pruned
Gig1/2      1
 

Basic switch setup - Packet Tracer

Introduction

A new switch just purchased from Cisco contains no default configuration in it. You need to configure the switch with setup mode using the setup mode or from scratch using the command line interface (CLI) before connecting it in your network environment. As a Cisco certified technician, it is very important to know the basic Cisco switch configuration commands to improve the performances and the security of your internetwork.

Lab instructions

This lab will test your ability to configure basic settings on a cisco switch.

1. Use the local laptop connect to the switch console.

2. Configure Switch hostname as LOCAL-SWITCH

3. Configure the message of the day as "Unauthorized access is forbidden"

4. Configure the password for privileged mode access as "cisco". The password must be md5 encrypted

5. Configure password encryption on the switch using the global configuration command

6. Configure CONSOLE access with the following settings :
- Login enabled
- Password : ciscoconsole
- History size : 15 commands
- Timeout : 6'45''
- Synchronous logging

6. Configure TELNET access with the following settings :
- Login enabled
- Password : ciscotelnet
- History size : 15 commands
- Timeout : 8'20''
- Synchronous logging

7. Configure the IP address of the switch as 192.168.1.2/24 and it's default gateway IP (192.168.1.1).

8. Test telnet connectivity from the Remote Laptop using the telnet client.


Network diagram



Solution

Configure Switch hostname as LOCAL-SWITCH
hostname LOCAL-SWITCH

Configure the message of the day as "Unauthorized access is forbidden"
banner motd #
Unauthorized access is forbidden#

Configure the password for privileged mode access as "cisco". The password must be md5 encrypted
enable secret cisco

Configure password encryption on the switch using the global configuration command
service password-encryption

Configure CONSOLE access [...]
line con 0
password ciscoconsole
logging synchronous
login
history size 15
exec-timeout 6 45

Configure TELNET access [...]
line vty 0 15
exec-timeout 8 20
password ciscotelnet
logging synchronous
login
history size 15

Configure the IP address of the switch as 192.168.1.2/24 and it's default gateway IP (192.168.1.1).
interface Vlan1
ip address 192.168.1.2 255.255.255.0
ip default-gateway 192.168.1.1





Packet Tracer - Setting up and managing a DHCP server


Introduction


DHCP (Dynamic Host Configuration Protocol) service is a key component of your network infrastructure by allowing centralized ip address management on a single pool of servers. DHCP configuration is also part of CCNA and CCNP Switch certification exams curricula. This skill can be tested in lab environnement during exams ans it's important for students to get used to DHCP configuration before taking the exam.
Packet Tracer 5.3 implements two methods for setting up a DHCP server in your network :
  • Configuration of DHCP pools on Cisco routers or multlayer switches.
  • Configuration of a standalone DHCP server appliance on the network and usage of the "ip helper-address" command on network devices for DHCP traffic forwarding outside each local broadcast domain. This tutorial will describe this method for implementing DHCP service in your network.

Tutorial description


This tutorial will show you how to configure dynamic IP address assignment on multiple VLAN with a unique DHCP server appliance on the network.
Two VLANs are configured on Switch0 with Router0 as default gateway :
  • VLAN 10 - Nework : 192.168.10.0/24 - Gateway : 192.168.10.1 (FA 0/0.10)
  • VLAN 20 - Network : 192.168.20.0/24 - Gateway : 192.168.20.1 (FA 0/0.20)
The unique DHCP server is located on a remote subnet with IP 172.16.24.2.


DHCP configuration

Declare IP address pools on the DHCP management tab of the server like on the picture below. One pool has to be declared for each VLAN. Don't forget to configure the right network settings and default gateway (Router0 FA 0/0.10 and FA 0.0.20 IP address) for each VLAN.

DHCP server configuration on packet tracer 5.3

Configure router0 for DHCP forwarding

Router(config)# interface FastEthernet0/0.10
Router(config-subif)# encapsulation dot1Q 10
Router(config-subif)# ip address 192.168.10.1 255.255.255.0
Router(config-subif)# ip helper-address 172.16.24.2

Router(config)# interface FastEthernet0/0.20
Router(config-subif)# encapsulation dot1Q 20
Router(config-subif)# ip address 192.168.20.1 255.255.255.0
Router(config-subif)# ip helper-address 172.16.24.2

[ Click on Images to Enlarge ]

Friday, April 27, 2012

Online Virtual Linux Command Line Terminal


Both websites provide virtual linux terminal which can be accessed through a web browser.

Website : http://cb.vu/


 
Website : http://www.masswerk.at/jsuix/